contextual related posts ve 403 forbidden hatası


Contextual Related Posts plugin, wordpress sitelerde kullanılan bir eklenti. Eklentinin amacı, site yazılarının altında benzer yazıları listeler. Bu eklentiye benzer başkaca eklenti nette mevcut. Türkçesi de olan bu eklenti, siteler için oldukça yararlı. Kurulumu ve ayarları oldukça basit. Bu eklentiye ihtiyaç duyarsanız; bu konu ile ilgili nette bir çok bilgi mevcut, dilediğiniz gibi yararlanabilirsiniz. Konumuz, benzer yazılar eklentisinin kurulumu ve ayarları değildir. O yüzden, eklentinin bu yanı ile ilgilenmeyeceğim. Anlatmaya çalışacağım konu, bu eklentiyi sitenize kurmakla başınıza ne işler açabileceği ile ilgilidir.

Contextual-related-posts eklentisinin nette kurulumu ve ayarları ile ilgili çokça belge bulabilirsiniz. Fakat, siteden nasıl kaldırılacağı ile ilgili hiç bir bilgiye ulaşamazsınız. İşte, sorunun kaynağı bu. Bir gün eklentiyi sitenizden kaldırmak istediğinizde, komutlarınızın hiç bir işe yaramadığına şahit olacaksınız. Eklenti dosyalarının chmod değerlerini hiç bir zaman, ne cpanelden ne de ftp'den değiştiremiyeceksiniz. Bu eklenti mıh gibi her zaman plugin dizini içerisinde sabit kalacaktır.

Eklentinin bu davranış biçimi sizde takıntı yapması kaçınılmazdır. Aklınıza geldikçe, bu eklentiyi silmek için cpaneli kullanmaya çalışacaksınız. Eklenti dosyalarını Cpanel siler gibi görünecek ve hiç bir zaman silmeyecek. Ve bir gün, Cpanel silmeye çalıştığınız bu eklenti için isyan edecek ve bütün cpanel, ftp kullanıcı yetkinizi elinizden alacak. Ondan sonra, cpanel'e giremiyeceksiniz. Ftp'ye girdiğinizde boş bir pencere ile karşılaşacaksınız ve hiç bir dosyanızı göremiyeceksiniz. Sitenize ulaşmaya çalıştığınızda;

"Forbidden
You don't have permission to access / on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

hatası ile karşılaşacaksınız. Bundan sonrası, sizin yapabileceğiniz, doğrudan hosting servis sağlayıcınız ile görüşerek sorunu halletmeniz olacaktır. Apache Server'lar, contextual-related-posts, wp-js, ve wp-css gibi kimi programların bazı dosyalarını sahiplendiği için, kullanıcıya erişim izni vermiyormuş. Bu nedenle, ilgili dosyalarla fazlaca uğraştığınızda saldırı kabul ediyor ve bütün kullanıcı izinlerinizi kilitliyormuş. Üste adlarını sıraladığım bu üç eklenti sitemin belası, onlarla birlikte yaşamaya çalışıyorum. Tavsiyem, bu üç eklentiden uzak durun. Nihayet, çözümünü buldum, anılan eklentilerden uzak durmayın.

Bu blogdaki popüler yayınlar

ctrl f tuşları ne işe yarar

nbsp nedir nasıl kullanılır

data-vocabulary.org schema deprecated uyarısı wordpress ve blogger çözümü